Jump to content

 

Photo

X axis number of labels instead of intervals


  • Please log in to reply
9 replies to this topic

#1 Vincent Croquette

Vincent Croquette

    Member

  • Members
  • PipPip
  • 27 posts
  • Gender:Male

Posted 23 February 2012 - 04:51 PM

Dear Visifire support team

Is it possible to define a number of labels for the x axis rather than an interval.
The problem with the interval is that when zooming into the chart, there are too few labels shown.

Another question on the X axis: is it possible to force the 1st label to be fully visible?

Thanks in advance

#2 shoaib

shoaib

    Advanced Member

  • Members
  • PipPipPip
  • 924 posts
  • Gender:Male
  • Location:Bangalore

Posted 24 February 2012 - 05:37 AM

Vincent,

Is it possible to define a number of labels for the x axis rather than an interval.

Unfortunately there is no option available to set the numbers of labels to be displayed in x-axis. This option is not feasible as if there will be fixed number of labels in x-axis then labels may overlap when size of the chart changes or when chart is in full ZoomOut mode.

In this case I suggest you not to set Interval property in Axis. If you do not set Interval property in x-axis then chart will automatically manage the number of labels in x-axis to be displayed without any overlap.

Another question on the X axis: is it possible to force the 1st label to be fully visible?

Try setting Angle property in AxisLabels to -90.

Regards,
Shoaib

#3 Vincent Croquette

Vincent Croquette

    Member

  • Members
  • PipPip
  • 27 posts
  • Gender:Male

Posted 24 February 2012 - 06:47 AM

Thanks Shoaib

But the users do not want to loose space at the bottom so -90 is not an option.
Additionally, the automatic interval property does not work properly when working with dates (see attached) :(

Attached Files



#4 mac

mac

    Advanced Member

  • Members
  • PipPipPip
  • 171 posts
  • Gender:Male

Posted 27 February 2012 - 07:48 AM

Few similar posts

http://www.visifire....hl=scrollviewer
http://www.visifire....hl=scrollviewer
http://www.visifire....?showtopic=1201

#5 Vincent Croquette

Vincent Croquette

    Member

  • Members
  • PipPip
  • 27 posts
  • Gender:Male

Posted 27 February 2012 - 08:04 AM

Few similar posts

http://www.visifire.com/forums/index.php?showtopic=911&hl=scrollviewer
http://www.visifire.com/forums/index.php?showtopic=725&hl=scrollviewer
http://www.visifire.com/forums/index.php?showtopic=1201


@Mac

Thanks for the link, that confirms my fears that it is not possible to have horizontal labels (angle = 0) without having the first label truncated.
But that does not explain why the chart is not able to find an appropriate interval in the case of the screenshot I sent.

#6 shoaib

shoaib

    Advanced Member

  • Members
  • PipPipPip
  • 924 posts
  • Gender:Male
  • Location:Bangalore

Posted 08 March 2012 - 12:15 PM

Hi Vincent,

I suggest you not to set Angle or Row properties in AxisLabels. If you don't set these properties then auto AxisLabels placement will work and the AxisLabels will not overlap each other.

Regards,
Shoaib

#7 Vincent Croquette

Vincent Croquette

    Member

  • Members
  • PipPip
  • 27 posts
  • Gender:Male

Posted 08 March 2012 - 03:09 PM

Shoaib

The problem is not that the labels overlap but that the first label is truncated even if angle and row are not specified (Scrolling is on).
See attachment.

Hi Vincent,

I suggest you not to set Angle or Row properties in AxisLabels. If you don't set these properties then auto AxisLabels placement will work and the AxisLabels will not overlap each other.

Regards,
Shoaib

Attached Files



#8 shoaib

shoaib

    Advanced Member

  • Members
  • PipPipPip
  • 924 posts
  • Gender:Male
  • Location:Bangalore

Posted 09 March 2012 - 12:52 PM

Hi Vincent,

Try setting suitable value for AxisOffset property in Axis and check.

Example:-

<vc:Chart.AxesX>
  <vc:Axis AxisOffset="0.02"/>
</vc:Chart.AxesX>
Regards,
Shoaib

#9 chandandey

chandandey

    Member

  • Members
  • PipPip
  • 12 posts

Posted 27 September 2012 - 07:23 AM

Hi Team Visifire,

I am creating chart dynamically.
When I am set View3D = true it will works perfectly, but if I use View3D=false or use default View3D means not use this property it will given an error
in AxisLabels is null.

I am using like this.
chart1.View3D="false";
Axis xAxis = new Axis();
xAxis.AxisLabels.Angle = -90;  // Error in this line AxisLabels is showing null while using View3D=false and no error while using View3D=true
chart1.AxesX.Add(xAxis);

Please suggest me the solution for this bug asap.

Thanks in advance.

Chandan Dey

#10 shoaib

shoaib

    Advanced Member

  • Members
  • PipPipPip
  • 924 posts
  • Gender:Male
  • Location:Bangalore

Posted 28 September 2012 - 04:53 AM

We have replied your query here.

Regards,
Shoaib




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users