Jump to content

 

Photo

when set the RenderAs="StackedColumn100" ,why it shows wrong result?


  • Please log in to reply
5 replies to this topic

#1 gissky

gissky

    Member

  • Members
  • PipPip
  • 11 posts

Posted 02 May 2012 - 12:59 PM

Sorrey,I am a new learner and My English skills is poor,but Please read my question Patiently,I need your help very much!

My question is : when I set the RenderAs="StackedColumn100" ,why it shows wrong result? But when I set the RenderAs="StackedBar100" ,it shows right result, the code show As follows:


<Grid>
	    <vc:Chart Theme="Theme1" Style="{StaticResource ChartStyle}">
		    <vc:Chart.Titles>
			    <vc:Title Text="Visifire Sample with Styling" Style="{StaticResource TitleStyle}"/>
		    </vc:Chart.Titles>
		    <vc:Chart.Series>
			    <vc:DataSeries RenderAs="StackedColumn100" Color="Red">
				    <vc:DataSeries.DataPoints>
					    <vc:DataPoint YValue="20"/>
					    <vc:DataPoint YValue="30"/>
					    <vc:DataPoint YValue="40"/>
					    <vc:DataPoint YValue="50"/>
				    </vc:DataSeries.DataPoints>
			    </vc:DataSeries>
			    <vc:DataSeries Color="Yellow" RenderAs="StackedColumn100" >
				    <vc:DataSeries.DataPoints>
					    <vc:DataPoint YValue="80"/>
					    <vc:DataPoint YValue="70"/>
					    <vc:DataPoint YValue="60"/>
					    <vc:DataPoint YValue="50"/>
				    </vc:DataSeries.DataPoints>
			    </vc:DataSeries>
		    </vc:Chart.Series>
	    </vc:Chart>
    </Grid>

please tell me what's wrong in my code,thank you very much!

Attached Files



#2 shoaib

shoaib

    Advanced Member

  • Members
  • PipPipPip
  • 924 posts
  • Gender:Male
  • Location:Bangalore

Posted 02 May 2012 - 01:54 PM

Hi Gissky,

We have fixed the issue. Please check with the latest internal release build here and let us know your feedback. You can expect public release of above build by the end of this week.

Regards,
Shoaib

#3 gissky

gissky

    Member

  • Members
  • PipPip
  • 11 posts

Posted 03 May 2012 - 01:21 AM

Thank You very much,The new .dll file is right!

#4 gissky

gissky

    Member

  • Members
  • PipPip
  • 11 posts

Posted 03 May 2012 - 03:56 AM

I was so keen to see the new version!

#5 shoaib

shoaib

    Advanced Member

  • Members
  • PipPipPip
  • 924 posts
  • Gender:Male
  • Location:Bangalore

Posted 04 May 2012 - 12:54 PM

Hi Gissky,

We have made a public release for Visifire 4.5.6.0 with the above fix. Please check the blog post here for more info.

Regards,
Shoaib

#6 gissky

gissky

    Member

  • Members
  • PipPip
  • 11 posts

Posted 06 May 2012 - 11:33 AM

Hi Gissky,

We have made a public release for Visifire 4.5.6.0 with the above fix. Please check the blog post here for more info.

Regards,
Shoaib


I have downloded the new version,thank you !




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users